Paypal to Ban Old Browsers

Paypal looks like it is going to start blocking browsers from it’s site that it feels to be unsafe. Paypal intends to target browsers that do not support Extended Validation Secure Sockets Layer (EV SSL). This feature is currently avalible in Internet Explorer 7 and the beta version of Firefox 3, unfortunatly browsers such as Apple Safari and Opera, do not currently include these protections.
Coverage