Apache 2.2.14 mod_isapi Dangling Pointer Exploit

Got a server running Apache HTTPd 2.2.14, I had, looks like there is an exploit that could ruin your day if your don’t patch.

“Successful exploitation results in the execution of arbitrary code with SYSTEM privileges.”